Friday, 24 February 2017

Juniper EX4300 40G QSFP+ Ports Configuration (Non VC-Ports)

The 40G ports on EX4300 Switches are configured as VC-PORTs by default. First remove VC-PORT configurations.

> request virtual-chassis vc-port delete pic-slot 1 port 0
> request virtual-chassis vc-port delete pic-slot 1 port 1
> request virtual-chassis vc-port delete pic-slot 1 port 2
> request virtual-chassis vc-port delete pic-slot 1 port 3

Then you need to configure no-auto-negotiation for the ports to become active.

# set interfaces et-0/1/0 ether-options no-auto-negotiation
# set interfaces et-0/1/1 ether-options no-auto-negotiation
# set interfaces et-0/1/2 ether-options no-auto-negotiation
# set interfaces et-0/1/3 ether-options no-auto-negotiation

Monday, 6 February 2017

Junos Copy Files From TFTP Server To Switch/Router

Login with "root" account

> file copy ftp://(TFTP IP Address or Hostname)/ex4300/jinstall-ex-4300-14.1X53-D40.8-domestic-signed.tgz /var/tmp/jinstall-ex-4300-14.1X53-D40.8-domestic-signed.tgz


Tuesday, 15 November 2016

Aruba Wireless Controller User Debug by MAC Address

controller (config) # logging level debugging user-debug <mac-address>

controller # show log user-debug all

Friday, 11 November 2016

Junos Restoring a Saved Backup Configuration

Once the saved configuration file is copied to the router, you load and commit the file:

Start the CLI configuration mode.

user@routername> configure
Entering configuration mode
 
[edit]
user@host#

Load the file into the current configuration. You should override the existing file.

user@host# load override /var/tmp/filename
load complete

Commit the file.

user@host# commit
commit complete

Thursday, 10 November 2016

DHCPv6 and Router Advertisements in Junos

Even if you intend to use DHCPv6 instead of SLAAC in your environment, you still need RA messages to function on the local LAN.  The RAs provide the default gateway information to an end node and, with the M-bit, inform the nodes that the LAN uses stateful DHCPv6

The RA contains several flags that are set that the nodes watch for and use.
  • A-bit – Autonomous Address Autoconfiguration Flag tells the node it should perform stateless address assignment (SLAAC RFC 4862)
  • L-bit – On-Link Flag tells the node that the prefix listed in the RA is the local IPv6 address
  • M-bit – Managed Address Config Flag tells the host if it should use stateful DHCPv6 (RFC 3315) to acquire its address and other DHCPv6 options
  • O-bit – Other Config Flag tells the host that there is other information the router can provide (such as DNS information defined in Stateless DHCPv6 (RFC 3736))



Junos RA config that is required for the DHCPv6 enabled infrastructure

set protocols router-advertisement interface <interface name> managed-configuration
set protocols router-advertisement interface <interface name> prefix <IPv6 Prefix> no-autonomous
set protocols router-advertisement interface <interface name> prefix <IPv6 Prefix> on-link

If the "on-link" option is not set for a prefix. Any host on that network sends all packets destined for the hosts on the same network to its default gateway. DHCPv6 does not send the prefix information to the client. When "on-link" is set the router informs the clients with the directly connected prefixes.

Juniper Troubleshooting Commands

TROUBLESHOOTING set cli timestamp (logs timestamp on cli for all commands you run. Very useful) show system uptime show chass...